FFMPEG-PHP: make: *** [ffmpeg_frame.lo] Error 1

hostripples.com/ffmpeg-php-make-ffmpeg_frame-lo-error-1/ffmpeg-logo/" data-orig-file="https://i1.wp.com/blog.hostripples.com/wp-content/uploads/2013/09/ffmpeg-logo.png?fit=396%2C100&ssl=1" data-orig-size="396,100" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":""}' data-image-title="ffmpeg-logo" data-image-description="" data-medium-file="https://i1.wp.com/blog.hostripples.com/wp-content/uploads/2013/09/ffmpeg-logo.png?fit=300%2C75&ssl=1" data-large-file="https://i1.wp.com/blog.hostripples.com/wp-content/uploads/2013/09/ffmpeg-logo.png?fit=396%2C100&ssl=1" loading="lazy" class="size-full wp-image-1366 aligncenter" alt=", FFMPEG-PHP: make: *** [ffmpeg_frame.lo] Error 1, Hostripples Web Hosting" src="http://blog.hostripples.com/wp-content/uploads/2013/09/ffmpeg-logo.png" width="396" height="100" srcset="https://i1.wp.com/blog.hostripples.com/wp-content/uploads/2013/09/ffmpeg-logo.png?w=396&ssl=1 396w, https://i1.wp.com/blog.hostripples.com/wp-content/uploads/2013/09/ffmpeg-logo.png?resize=300%2C75&ssl=1 300w" sizes="(max-width: 396px) 100vw, 396px">

While compiling ffmpeg-php from source with make command you may get the following error terminating your making process;

make: *** [ffmpeg_frame.lo] Error 1

 

This error occurs due to a missing file ‘ffmpeg_frame.lo‘ in the ffmpeg-php source, while your ffmpeg-php source may contain the file named ‘ffmpeg_frame.loT‘.

 

To Resolve this issue you just need to rename the ‘ffmpeg_frame.loT‘ to ‘ffmpeg_frame.lo‘ and make again, Please check below steps :

Go to ffmpeg-php source directory :

Note: your ffmpeg-php version may be different, i am using 0.6.0

[root@hostripples ~]# cd /path/to/ffmpeg-php-0.6.0

Now rename or copy the ‘ffmpeg_frame.loT‘ to ‘ffmpeg_frame.lo

[root@hostripples ~]# mv ffmpeg_frame.loT ffmpeg_frame.lo

Once you have successfully renamed/copied the file to ‘ffmpeg_frame.lo’, you should compile it again with make command.